フェンリル

Developer's Blog

【PictBear】脆弱性に対応した PictBear 2.01 正式版をリリースいたしました!

PictBear 2.01
こんにちは、フェンリル開発担当のたばです。
本日、脆弱性が修正された PNG ライブラリに更新した PictBear 2.01 正式版をリリースいたしました。
下記リンクからダウンロードできます。
【PictBear 2.01 正式版ダウンロードページ】
PictBear 2.0 は PNG ライブラリに脆弱性がありますので、使用されている方は必ずアップデートしてください。
PNG ライブラリの脆弱性に関する情報は下記をご覧下さい。
libpng における圧縮された補助チャンクの処理に脆弱性
今後もフェンリル / PictBear をよろしくお願いします。

Facebook コメント

コメント

G-San2010年03月04日 16:21

上書きインストールでOKですか?

たば2010年03月04日 16:22

> G-San さん
はい。上書きインストールで OK です。

G-San2010年03月04日 17:36

> たば さん
どうもです。先程インストールしました。
PictBearに限らず、体に気を付けて開発頑張って下さい。

rei2010年03月04日 19:07

Sleipnirにも影響があるはずですが
いつたいおうしますか?

yamauti2010年03月04日 21:54

この記事とは関係ないのですが、
http://blog.fenrir-inc.com/jp/2009/04/_sleipnir_start_seahorse_2.html
は今は使えないのですか?

domo2010年03月05日 0:42

PictBearは開発停止(完了)扱いでアップデートされないかと思ってました。
愛用しているのでアップデート必至です。
SleipnirについてはWindowsアップデートでIEの脆弱性が修正されれば、Sleipnir自体の修正は不要ですよね?
PNGを処理しているのはTridentの方だろうし…?

rei2010年03月05日 15:44

domoさん。
Geckoビューワーは対応できていないと思います。

ヤマダケンイチ2010年03月14日 21:28

PictBearをダウンロードしましたが、英語版でした。日本語版をインストールしたいのですが、何処にあるのか解りません。在るとしたら其のまま上書きインストールしたらいいのでしょうか。

コルア2010年03月15日 3:31

ヤマダケンイチさん>>
通りすがりですがお答えします、
恐らくピクトベアー初起動の時
[eng]と[jap]のうち、engを選びませんでしたか?
これ、[english]と[japanese]の略称なので
日本語の場合はjapを選ばなきゃです
確か途中から変更できなかったと思うので
一度アンインストールしてからもう一度DLして下さい

アクア2010年03月20日 21:03

アップデートしました。

パトあき2010年04月27日 21:10

Windows7 32bit版で使用していますが、XPの時に初期バージョンのPictbearで使えていた
ドラッグ&ドロップでのファイル読み込みが出来なくなっています。
(ファイル→開く からは出来る)
よって、追加ブラシもインストールできず、どうしたらいいものかと…

ナツ2010年05月04日 17:11

先日月イチのウイルススキャンをしたところ、
PictBearSEの plugins>imports>impBmp.ppi
にマルウェアが発見されたとの結果が出ました。
ウイルス名はWin32.MalWare.Heur_Generic.A.77824とのこと。
駆除するともちろん使えなくなるのでBMP画像の読み込みが出来なくなります。脆弱性が発見されアップデートされたとのことで、DL→再インストールしてみましたがスキャンしたらまた同じ物に引っ掛かりました。
ソフトはkingsoft Internet Security U SP1です。
無駄に敏感に反応しているだけならいいのですが少し心配で、以前から愛用させていただいている物なので今後も継続したいと思うのですが…。
同じようになられた方はおりますでしょうか。

ナツ2010年05月04日 17:14

先日月イチのウイルススキャンをしたところ、
PictBearSEの plugins>imports>impBmp.ppi
にマルウェアが発見されたとの結果が出ました。
ウイルス名はWin32.MalWare.Heur_Generic.A.77824とのこと。
駆除するともちろん使えなくなるのでBMP画像の読み込みが出来なくなります。脆弱性が発見されアップデートされたとのことで、DL→再インストールしてみましたがスキャンしたらまた同じ物に引っ掛かりました。
ソフトはkingsoft Internet Security U SP1です。
無駄に敏感に反応しているだけならいいのですが少し心配で、以前から愛用させていただいている物なので今後も継続したいと思うのですが…。
同じようになられた方はおりますでしょうか。

2010年05月28日 9:22

最近パソコンをWindows7へ買い替えました。
買い替える前はXPでPictBear SEを使用出来ていました。
買い替え後インストールしようとしたらSEが無くなっていて
PictBearをインストールしたのですが起動させると
PictBear は動作を停止しました
問題が発生したため、プログラムが正しく動作しなくなりました。
と、報告があり強制的に閉じられてしまいます。
ブラシも未だ何も登録していません。
何度もアンインストールしては再インストールをしましたが起動しません。
調べてみてはいるのですが他に解決法も無く困っております。
どうしたら宜しいでしょうか?

ゆいか2010年06月30日 22:33

ブラシが追加できないのですが、どうすればいいでしょうか?

名前(必須)

メールアドレス(必須)

URL

スタイル用のタグが使えます

このコメント欄でのご質問、ご要望には、開発チームから回答できない場合があります。ご質問、ご要望は「User Community」内のフォーラムまでお寄せください。